MOSS Infrastructure Update – Configuration Wizard Failure

Applying the IU to the application server in my SharePoint farm worked perfectly but when I ran through the configuration wizard on the WFE I got this error:

An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown. Additional exception information: Failed to upgrade SharePoint Products and Technologies

The diagnostic logs reported the same helpful error but after finding this guy had come across the same issue and consequenetly riffling around in the SharePoint logs I found an ACL error on C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\template\layouts\web.config which in fact did not exist in this location. I still have no idea why the web.config was missing (I’m assuming it was meant to be replaced but only the delete occurred) but a simple file copy from the app server allowed me to re-run the config wizard and complete the install successfully.

Advertisements

One thought on “MOSS Infrastructure Update – Configuration Wizard Failure

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s